Printix Client does not know its Printix Home

When this is the case, the Printix ID in Windows Registry is not set. This can happen if:

  • The Printix Client installation file was renamed before installation.
  • The Printix Client MSI file was deployed via for example Microsoft Intune, but in command line arguments :/id was not set correctly.

RESOLUTION: Do NOT rename the file before installation. Type the Command line arguments correctly, for example: WRAPPED_ARGUMENTS=/id:cbfce0b5-da2a-4cb6-b7f7-a04ee31cac90. Replace the /id value with your Printix ID as show in the name of the MSI file.

Is a web proxy and/or SSL inspection used?

In this case the PrintixService.log file will contain the text: SrvComm Exception: Status: ProxyAuthenticationRequired.

RESOLUTION: You MUST add the printix.net domain and subdomains as exceptions so traffic is not blocked. See also: Web proxy and SSL inspection

I do not recognize the used web proxy

In this case the PrintixService.log file will contain the text like this:ServerComm: running with proxy1: https://172.23.100.13:8080/ and Unable to connect to the remote server.

RESOLUTION: Refer to: How does Printix Client find the web proxy?

Is FIPS (Federal Information Processing Standards) enabled on the computer?

Enabling FIPS disallows the use of the MD5 hashing algorithm, which is used by Printix Client to make some entries in the Windows Registry “tamper-resistant”.

RESOLUTION: Disable FIPS.

  1. Select Windows Key+R to open Run.
  2. Type: regedit, and select OK.
  3. In Registry Editor browse to:
    HKEY_LOCAL_MACHINE\SYSTEM\
    CurrentControlSet\Control\Lsa\FipsAlgorithmPolicy
  4. Change the value Enabled to 0.
  5. If present, also change the value MDMEnabled to 0.
  6. Restart the computer.

PowerShell script

Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Control\Lsa\FipsAlgorithmPolicy" -Name "MDMEnabled" -Value 0

Feedback

Was this helpful?

Yes No
You indicated this topic was not helpful to you ...
Could you please leave a comment telling us why? Thank you!
Thanks for your feedback.

Post your comment on this topic.

Please do not use this for support questions.
Printix Support

Post Comment